[Bug 24837] New: selectbranchprinter needs to be renamed
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Bug ID: 24837 Summary: selectbranchprinter needs to be renamed Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: jonathan.druart@bugs.koha-community.org QA Contact: testopia@bugs.koha-community.org script and template selectbranchprinter[.pl|.tt] should be renamed. Bug 17845 removed the branchprinter feature, so the script should be named select_library or equivalent. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Depends on| |17845 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17845 [Bug 17845] Remove printer related code -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |katrin.fischer@bsz-bw.de |ity.org | CC| |katrin.fischer@bsz-bw.de -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff Patch complexity|--- |Small patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 --- Comment #1 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 100715 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=100715&action=edit Bug 24837: Rename selectbranchprinter.pl to set-library.pl This renames the selectbranchprinter.pl file to the more fitting set-library.pl. To test: - Change the library with "Set library" from - The menu in the top navigation bar - The circulation start page - Verify the help link on page leads to the correct section in the manual - Read the code... and verify all occurences have been caught -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Lucas Gass <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |lucas@bywatersolutions.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #100715|0 |1 is obsolete| | --- Comment #2 from Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> --- Created attachment 101371 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=101371&action=edit Bug 24837: Rename selectbranchprinter.pl to set-library.pl This renames the selectbranchprinter.pl file to the more fitting set-library.pl. To test: - Change the library with "Set library" from - The menu in the top navigation bar - The circulation start page - Verify the help link on page leads to the correct section in the manual - Read the code... and verify all occurences have been caught Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> Works ok, fixed tab char in circ/branchtransfers.pl -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #101371|0 |1 is obsolete| | --- Comment #3 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 101457 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=101457&action=edit Bug 24837: Rename selectbranchprinter.pl to set-library.pl This renames the selectbranchprinter.pl file to the more fitting set-library.pl. To test: - Change the library with "Set library" from - The menu in the top navigation bar - The circulation start page - Verify the help link on page leads to the correct section in the manual - Read the code... and verify all occurences have been caught Signed-off-by: Bernardo Gonzalez Kriegel <bgkriegel@gmail.com> Works ok, fixed tab char in circ/branchtransfers.pl Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com --- Comment #4 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Thanks for grabbing this one :) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)| |20.05.00 released in| | Status|Passed QA |Pushed to master -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 --- Comment #5 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Nice work everyone! Pushed to master for 20.05 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24837 Joy Nelson <joy@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |joy@bywatersolutions.com --- Comment #6 from Joy Nelson <joy@bywatersolutions.com> --- not backported to 19.11.x -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org