[Bug 9545] New: Fix Import Marc Bibliographic Framework Text Label
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 Bug ID: 9545 Summary: Fix Import Marc Bibliographic Framework Text Label Classification: Unclassified Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: minor Priority: P5 - low Component: Templates Assignee: oleonard@myacpl.org Reporter: dcook@prosentient.com.au Currently, when you click on "Import" next to a MARC Bibliographic Framework, you are prompted for a "Spreadsheet file", even though you can supply SQL files as well as CSV/XLS/(perhaps also the Open Document Format for spreadsheets). -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |ASSIGNED -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 --- Comment #1 from Owen Leonard <oleonard@myacpl.org> --- Created attachment 15240 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=15240&action=edit Bug 9545 - Fix import MARC bibliographic framework text label This patch improves the labeling of import controls on the MARC frameworks page by making import options more explicit. Other changes: - Form markup fixed to match standard form constructions - JavaScript corrected to make more embedded English strings translatable. - Form labels made clickable by making "for" attributes match unique form field ids. - Some warning re-worded for readability and translatability. - Large "loading" icon replaced with more proportional smaller one. To test, view the MARC frameworks page (admin/biblio_framework.pl) and test Export and Import functionality. Clicking each should display a form with options clearly labeled. Import and Export operations should complete correctly. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 --- Comment #2 from Owen Leonard <oleonard@myacpl.org> --- Add this to the list of operations that would be better handled by a modal dialog--perhaps via jQueryUI or Bootstrap if we find we can replace Greybox with one of them. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 --- Comment #3 from David Cook <dcook@prosentient.com.au> --- Created attachment 15288 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=15288&action=edit [SIGNED-OFF] Bug 9545 - Fix import MARC bibliographic framework text label This patch improves the labeling of import controls on the MARC frameworks page by making import options more explicit. Other changes: - Form markup fixed to match standard form constructions - JavaScript corrected to make more embedded English strings translatable. - Form labels made clickable by making "for" attributes match unique form field ids. - Some warning re-worded for readability and translatability. - Large "loading" icon replaced with more proportional smaller one. To test, view the MARC frameworks page (admin/biblio_framework.pl) and test Export and Import functionality. Clicking each should display a form with options clearly labeled. Import and Export operations should complete correctly. Signed-off-by: David Cook <dcook@prosentient.com.au> Works as described, although I see what Owen means about it being a good candidate for replacement with a modal dialog box in the future. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #15240|0 |1 is obsolete| | Attachment #15288|0 |1 is obsolete| | --- Comment #4 from David Cook <dcook@prosentient.com.au> --- Created attachment 15289 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=15289&action=edit [SIGNED-OFF] Bug 9545 - Fix import MARC bibliographic framework text label This patch improves the labeling of import controls on the MARC frameworks page by making import options more explicit. Other changes: - Form markup fixed to match standard form constructions - JavaScript corrected to make more embedded English strings translatable. - Form labels made clickable by making "for" attributes match unique form field ids. - Some warning re-worded for readability and translatability. - Large "loading" icon replaced with more proportional smaller one. To test, view the MARC frameworks page (admin/biblio_framework.pl) and test Export and Import functionality. Clicking each should display a form with options clearly labeled. Import and Export operations should complete correctly. Signed-off-by: David Cook <dcook@prosentient.com.au> Works as described, although I see what Owen means about it being a good candidate for replacement with a modal dialog box in the future. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 Owen Leonard <oleonard@myacpl.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA CC| |jonathan.druart@biblibre.co | |m Patch complexity|--- |Small patch QA Contact| |jonathan.druart@biblibre.co | |m --- Comment #5 from Jonathan Druart <jonathan.druart@biblibre.com> --- QA comment: Works great. The export action for the default framework don't work. I will provide a followup. Owen, yesterday for dialogs I found Bootbox.js (http://bootboxjs.com). Perhaps it could be useful for us. Marked as Passed QA. TODO: some code could be factorize (default framework and others). -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 Jonathan Druart <jonathan.druart@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #15289|0 |1 is obsolete| | --- Comment #6 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 15321 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=15321&action=edit Bug 9545 - Fix import MARC bibliographic framework text label This patch improves the labeling of import controls on the MARC frameworks page by making import options more explicit. Other changes: - Form markup fixed to match standard form constructions - JavaScript corrected to make more embedded English strings translatable. - Form labels made clickable by making "for" attributes match unique form field ids. - Some warning re-worded for readability and translatability. - Large "loading" icon replaced with more proportional smaller one. To test, view the MARC frameworks page (admin/biblio_framework.pl) and test Export and Import functionality. Clicking each should display a form with options clearly labeled. Import and Export operations should complete correctly. Signed-off-by: David Cook <dcook@prosentient.com.au> Works as described, although I see what Owen means about it being a good candidate for replacement with a modal dialog box in the future. Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 --- Comment #7 from Jonathan Druart <jonathan.druart@biblibre.com> --- Created attachment 15322 --> http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=15322&action=edit Bug 9545 - Followup Fix import MARC bibliographic framework text label The export action for the default framework did not work. Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com> -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 --- Comment #8 from Jonathan Druart <jonathan.druart@biblibre.com> --- Last patch just replaces input type="button" with input type="submit" -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 Jared Camins-Esakov <jcamins@cpbibliography.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master --- Comment #9 from Jared Camins-Esakov <jcamins@cpbibliography.com> --- This patch has been pushed to master. -- You are receiving this mail because: You are watching all bug changes.
http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9545 Chris Cormack <chris@bigballofwax.co.nz> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |Pushed to Stable CC| |chris@bigballofwax.co.nz --- Comment #10 from Chris Cormack <chris@bigballofwax.co.nz> --- Pushed to 3.8.x and 3.10.x will be in 3.8.11 and 3.10.4 -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org