[Bug 28813] New: Delivery notes feature was pushed prior to it's completion
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Bug ID: 28813 Summary: Delivery notes feature was pushed prior to it's completion Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Notices Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org Depends on: 14723 Bug 14723 somehow made it through QA with some fields missing from the database and some functions missing corresponding updates (for translation handling). We all make mistakes.. oops. This bug will serve to add the correct DB update and changes to kohastructure and update the relevant function. See bug 14723 comment 60 for further details. Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14723 [Bug 14723] Additional delivery notes to messages -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Assignee|koha-bugs@lists.koha-commun |martin.renvoize@ptfs-europe |ity.org |.com -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Severity|enhancement |normal -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |28803 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28803 [Bug 28803] process_message_queue.pl dies if any messsages in the message queue contain an invalid to_address -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 --- Comment #1 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 123471 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123471&action=edit Bug 28813: Update database field name Update the database field name from 'delivery_note' to 'failure_code' to more accurately denote it's use. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 --- Comment #2 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 123472 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123472&action=edit Bug 28813: DBIC Schema Update -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 --- Comment #3 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 123473 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123473&action=edit Bug 28813: Update unit tests This patch updates the unit tests to check for failure_code instead of delivery_note and catches a missing case. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 --- Comment #4 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Created attachment 123474 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123474&action=edit Bug 28813: Rename delivery_note to failure_code We now use the codes from the half implimented error_code in place of the plain text that was being added to the delivery_note field. As part of that we rename the field to failure_code to clarify it's intended content. Test plan 1/ Confirm t/db_dependent/Letters.t passes -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart+koha@gmail. | |com, | |kyle@bywatersolutions.com, | |tomascohen@gmail.com -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #123471|0 |1 is obsolete| | --- Comment #5 from David Nind <david@davidnind.com> --- Created attachment 123536 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123536&action=edit Bug 28813: Update database field name Update the database field name from 'delivery_note' to 'failure_code' to more accurately denote it's use. Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #123472|0 |1 is obsolete| | --- Comment #6 from David Nind <david@davidnind.com> --- Created attachment 123537 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123537&action=edit Bug 28813: DBIC Schema Update Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #123473|0 |1 is obsolete| | --- Comment #7 from David Nind <david@davidnind.com> --- Created attachment 123538 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123538&action=edit Bug 28813: Update unit tests This patch updates the unit tests to check for failure_code instead of delivery_note and catches a missing case. Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #123474|0 |1 is obsolete| | --- Comment #8 from David Nind <david@davidnind.com> --- Created attachment 123539 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123539&action=edit Bug 28813: Rename delivery_note to failure_code We now use the codes from the half implimented error_code in place of the plain text that was being added to the delivery_note field. As part of that we rename the field to failure_code to clarify it's intended content. Test plan 1/ Confirm t/db_dependent/Letters.t passes Signed-off-by: David Nind <david@davidnind.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 David Nind <david@davidnind.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |david@davidnind.com --- Comment #9 from David Nind <david@davidnind.com> --- Testing notes (koha-testing-docker): - prove t/db_dependent/Letters.t (before apply patches) - apply patches - updatedatabase + dbic - flush_memcached - restart_all - prove t/db_dependent/Letters.t (tests should pass) Hope that is sufficient for testing. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dcook@prosentient.com.au Summary|Delivery notes feature was |Delivery notes feature was |pushed prior to it's |pushed prior to its |completion |completion -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |rel_21_05_candidate -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA Patch complexity|--- |Medium patch -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #123536|0 |1 is obsolete| | --- Comment #10 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 123667 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123667&action=edit Bug 28813: Update database field name Update the database field name from 'delivery_note' to 'failure_code' to more accurately denote it's use. Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #123537|0 |1 is obsolete| | --- Comment #11 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 123668 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123668&action=edit Bug 28813: DBIC Schema Update Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #123538|0 |1 is obsolete| | --- Comment #12 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 123669 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123669&action=edit Bug 28813: Update unit tests This patch updates the unit tests to check for failure_code instead of delivery_note and catches a missing case. Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #123539|0 |1 is obsolete| | --- Comment #13 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Created attachment 123670 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=123670&action=edit Bug 28813: Rename delivery_note to failure_code We now use the codes from the half implimented error_code in place of the plain text that was being added to the delivery_note field. As part of that we rename the field to failure_code to clarify it's intended content. Test plan 1/ Confirm t/db_dependent/Letters.t passes Signed-off-by: David Nind <david@davidnind.com> Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 --- Comment #14 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Tested similarly as David, additionally updated failure_code in my database to check the display on the notices tab. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 --- Comment #15 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Maybe we could update the bug description a bit, keeping release notes in mind. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to master Version(s)| |21.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 --- Comment #16 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- Pushed to master for 21.11, thanks to everybody involved! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Summary|Delivery notes feature was |Fix recording and display |pushed prior to its |of delivery errors for |completion |patron notices -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 --- Comment #17 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- (In reply to Katrin Fischer from comment #15)
Maybe we could update the bug description a bit, keeping release notes in mind.
Done. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Version(s)|21.11.00 |21.11.00,21.05.03 released in| | Status|Pushed to master |Pushed to stable --- Comment #18 from Kyle M Hall <kyle@bywatersolutions.com> --- Pushed to 21.05.x for 21.05.03 -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Fridolin Somers <fridolin.somers@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |fridolin.somers@biblibre.co | |m --- Comment #19 from Fridolin Somers <fridolin.somers@biblibre.com> --- Depends on Bug 14723 not in 20.11.x -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28813 Jonathan Druart <jonathan.druart+koha@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|rel_21_05_candidate | -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org