[Bug 19303] New: Move C4::Members::GetFirstValidEmailAddress to Koha:: Patron->first_valid_email_address
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 Bug ID: 19303 Summary: Move C4::Members::GetFirstValidEmailAddress to Koha::Patron->first_valid_email_address Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: ASSIGNED Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: jonathan.druart@bugs.koha-community.org Reporter: jonathan.druart@bugs.koha-community.org QA Contact: testopia@bugs.koha-community.org This new Koha::Patron->first_valid_email_address already exists, it should be called directly. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |19304 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19304 [Bug 19304] Move C4::Members::GetNoticeEmailAddress to Koha::Patron->notice_email_address -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Blocks| |16846 Referenced Bugs: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16846 [Bug 16846] Move patron related code to Koha::Patron -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|ASSIGNED |Needs Signoff -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 --- Comment #1 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 67125 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=67125&action=edit Bug 19303 - Move C4::Members::GetFirstValidEmailAddress to Koha::Patron->first_valid_email_address This new Koha::Patron->first_valid_email_address already exists, it should be called directly Test plan: With a logged in user who have an email address defined, send a basket. The email should be marked sent by this email address -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #67125|0 |1 is obsolete| | --- Comment #2 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 67137 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=67137&action=edit Bug 19303: Move C4::Members::GetFirstValidEmailAddress to Koha::Patron->first_valid_email_address This new Koha::Patron->first_valid_email_address already exists, it should be called directly Test plan: - With a logged in user who have an email address defined, send a basket. The email should be marked sent by this email address - On the "Holds awaiting pickup", the email address must be displayed as well -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 David Bourgault <david.bourgault@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 David Bourgault <david.bourgault@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #67137|0 |1 is obsolete| | --- Comment #3 from David Bourgault <david.bourgault@inlibro.com> --- Created attachment 68107 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=68107&action=edit Bug 19303: Move C4::Members::GetFirstValidEmailAddress to Koha::Patron->first_valid_email_address This new Koha::Patron->first_valid_email_address already exists, it should be called directly Test plan: - With a logged in user who have an email address defined, send a basket. The email should be marked sent by this email address - On the "Holds awaiting pickup", the email address must be displayed as well Signed-off-by: David Bourgault <david.bourgault@inlibro.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Patch complexity|--- |Small patch CC| |josef.moravec@gmail.com QA Contact|testopia@bugs.koha-communit |josef.moravec@gmail.com |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 Josef Moravec <josef.moravec@gmail.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #68107|0 |1 is obsolete| | --- Comment #4 from Josef Moravec <josef.moravec@gmail.com> --- Created attachment 70221 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=70221&action=edit Bug 19303: Move C4::Members::GetFirstValidEmailAddress to Koha::Patron->first_valid_email_address This new Koha::Patron->first_valid_email_address already exists, it should be called directly Test plan: - With a logged in user who have an email address defined, send a basket. The email should be marked sent by this email address - On the "Holds awaiting pickup", the email address must be displayed as well Signed-off-by: David Bourgault <david.bourgault@inlibro.com> Signed-off-by: Josef Moravec <josef.moravec@gmail.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to Master --- Comment #5 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Pushed to master for 18.05, thanks to everybody involved! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19303 Nick Clemens <nick@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to Master |RESOLVED CC| |nick@bywatersolutions.com Resolution|--- |FIXED --- Comment #6 from Nick Clemens <nick@bywatersolutions.com> --- Enhancement, skipping for 17.11.x. Awesome work everybody! -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org