[Bug 37850] New: branchillemail missing from public libraries REST endpoint
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Bug ID: 37850 Summary: branchillemail missing from public libraries REST endpoint Change sponsored?: --- Product: Koha Version: Main Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: REST API Assignee: koha-bugs@lists.koha-community.org Reporter: pedro.amorim@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org CC: tomascohen@gmail.com -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Pedro Amorim <pedro.amorim@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|NEW |Needs Signoff -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 --- Comment #1 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- Created attachment 171102 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=171102&action=edit Bug 37850: Add branchillemail to libraries public REST endpoint To test, before applying patch: 1) Visit <opac_url>/api/v1/public/libraries 2) Notice illemail is not shown for each library 3) Apply patch. Restart plack 4) Repeat 1). Notice illemail is now shown for each library -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Phil Ringnalda <phil@chetcolibrary.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |phil@chetcolibrary.org Assignee|koha-bugs@lists.koha-commun |pedro.amorim@ptfs-europe.co |ity.org |m -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Maryse Simard <maryse.simard@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #171102|0 |1 is obsolete| | --- Comment #2 from Maryse Simard <maryse.simard@inlibro.com> --- Created attachment 172000 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=172000&action=edit Bug 37850: Add branchillemail to libraries public REST endpoint To test, before applying patch: 1) Visit <opac_url>/api/v1/public/libraries 2) Notice illemail is not shown for each library 3) Apply patch. Restart plack 4) Repeat 1). Notice illemail is now shown for each library Signed-off-by: Maryse Simard <maryse.simard@inlibro.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Maryse Simard <maryse.simard@inlibro.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |maryse.simard@inlibro.com Status|Needs Signoff |Signed Off -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |kyle@bywatersolutions.com QA Contact|testopia@bugs.koha-communit |kyle@bywatersolutions.com |y.org | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #172000|0 |1 is obsolete| | --- Comment #3 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 172003 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=172003&action=edit Bug 37850: Add branchillemail to libraries public REST endpoint To test, before applying patch: 1) Visit <opac_url>/api/v1/public/libraries 2) Notice illemail is not shown for each library 3) Apply patch. Restart plack 4) Repeat 1). Notice illemail is now shown for each library Signed-off-by: Maryse Simard <maryse.simard@inlibro.com> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to main Version(s)| |24.11.00 released in| | -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 --- Comment #4 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Pushed for 24.11! Well done everyone, thank you! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 --- Comment #5 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I am not a big fan of illemail as the name for the API, but this predates the patch. I think ill_email at least would have been a bit more consistent and easier to read. But too late. ;) -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 --- Comment #6 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- Created attachment 173042 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=173042&action=edit Bug 37850: (QA follow-up): Update illemail REST API attribute name To test 1) yarn api:bundle && koha-plack --restart kohadev 2) Enable ILLModule and put some 'ILL staff email:' on some library 3) Access <staff_url>/api/v1/libraries 4) Notice the attribute reads ill_email -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Pedro Amorim <pedro.amorim@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |additional_work_needed CC| |pedro.amorim@ptfs-europe.co | |m --- Comment #7 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- (In reply to Katrin Fischer from comment #5)
I am not a big fan of illemail as the name for the API, but this predates the patch. I think ill_email at least would have been a bit more consistent and easier to read. But too late. ;)
I agree. Patch is added if you decide to push. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 --- Comment #8 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Pedro Amorim from comment #7)
(In reply to Katrin Fischer from comment #5)
I am not a big fan of illemail as the name for the API, but this predates the patch. I think ill_email at least would have been a bit more consistent and easier to read. But too late. ;)
I agree. Patch is added if you decide to push.
Do you think it's save to push/not used much yet? Thinking of compatibility. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 --- Comment #9 from Pedro Amorim <pedro.amorim@ptfs-europe.com> --- (In reply to Katrin Fischer from comment #8)
(In reply to Pedro Amorim from comment #7)
(In reply to Katrin Fischer from comment #5)
I am not a big fan of illemail as the name for the API, but this predates the patch. I think ill_email at least would have been a bit more consistent and easier to read. But too late. ;)
I agree. Patch is added if you decide to push.
Do you think it's save to push/not used much yet? Thinking of compatibility.
Given that this was pushed to main 2 hours ago, I'd be very surprised if anyone is using this (we are, but we're aware of this last moment change). -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 --- Comment #10 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Pedro Amorim from comment #9)
(In reply to Katrin Fischer from comment #8)
(In reply to Pedro Amorim from comment #7)
(In reply to Katrin Fischer from comment #5)
I am not a big fan of illemail as the name for the API, but this predates the patch. I think ill_email at least would have been a bit more consistent and easier to read. But too late. ;)
I agree. Patch is added if you decide to push.
Do you think it's save to push/not used much yet? Thinking of compatibility.
Given that this was pushed to main 2 hours ago, I'd be very surprised if anyone is using this (we are, but we're aware of this last moment change).
I was thinking of the non-public route for libraries. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Martin Renvoize (ashimema) <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords| |release-notes-needed -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Pedro Amorim <pedro.amorim@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|release-notes-needed | Text to go in the| |This enhancement adds the release notes| |library's e-mail address | |for interlibrary loans to | |the following public REST | |API endpoint's response: | |<opac_url>/api/v1/public/li | |braries -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Martin Renvoize (ashimema) <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |martin.renvoize@ptfs-europe | |.com --- Comment #11 from Martin Renvoize (ashimema) <martin.renvoize@ptfs-europe.com> --- Please push the follow-up.. we've gone from a 2 hour turn around on a patch to a 3 week delay!.. whilst there was zero chance of code being in production at time of writing, there's not a still low but not zero chance given the code has now been published for weeks not hours. Still not released however so should certainly not be held up any longer. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Martin Renvoize (ashimema) <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Pushed to main |Passed QA -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 --- Comment #12 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- (In reply to Martin Renvoize (ashimema) from comment #11)
Please push the follow-up.. we've gone from a 2 hour turn around on a patch to a 3 week delay!.. whilst there was zero chance of code being in production at time of writing, there's not a still low but not zero chance given the code has now been published for weeks not hours. Still not released however so should certainly not be held up any longer.
ill_email on the non-public route is already released, so there is a change we are using it. I am not sure if it's used internally or not, I can try and test. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Keywords|additional_work_needed | --- Comment #13 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- I didn't spot any occurences. Picked follow-up for main. -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Katrin Fischer <katrin.fischer@bsz-bw.de> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Passed QA |Pushed to main -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 --- Comment #14 from Katrin Fischer <katrin.fischer@bsz-bw.de> --- Pushed for 24.11! Well done everyone, thank you! -- You are receiving this mail because: You are watching all bug changes.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37850 Lucas Gass (lukeg) <lucas@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Resolution|--- |FIXED CC| |lucas@bywatersolutions.com Status|Pushed to main |RESOLVED --- Comment #15 from Lucas Gass (lukeg) <lucas@bywatersolutions.com> --- Enhancement, no 24.05.x backport. -- You are receiving this mail because: You are watching all bug changes.
participants (1)
-
bugzilla-daemon@bugs.koha-community.org