Koha-bugs
Threads by month
- ----- 2026 -----
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2025 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2024 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2023 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2022 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2021 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2020 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2019 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2018 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2017 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2016 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2015 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2014 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2013 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2012 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2011 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2010 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2009 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2008 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2007 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2006 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2005 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2004 -----
- December
- November
- October
- September
- August
- July
- June
- May
- April
- March
- February
- January
- ----- 2003 -----
- December
- November
- October
- September
- August
- July
- June
- May
August 2026
- 1 participants
- 1811 discussions
[Bug 11999] Add two checks in CanBookBeReserved and CanItemBeReserved
by bugzilla-daemon@bugs.koha-community.org 01 Aug '26
by bugzilla-daemon@bugs.koha-community.org 01 Aug '26
01 Aug '26
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11999
David Nind <david(a)davidnind.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Text to go in the|This fixes placing holds |This fixes placing holds
release notes|when using ILS-DI - the |when using ILS-DI. The
|value set in maxreserves |value set in maxreserves
|(for example 1) was |system preference (for
|ignored, and you could |example 1) was ignored, and
|place more holds than |you could place more holds
|maxreserves.
|than maxreserves.
|
|
|Note: When placing holds |Note: When placing holds
|using the OPAC or staff |using the OPAC or staff
|interface, the value set in |interface, the value set in
|maxreserves is taken into |maxreserves continues to
|account. (That is, you |work as expected. (That is,
|can't place more holds than |you can't place more holds
|what is set in maxreserves |than what is set in
|using the OPAC or staff |maxreserves using the OPAC
|interface.) |or staff interface.)
Status|Needs Signoff |Failed QA
--- Comment #147 from David Nind <david(a)davidnind.com> ---
Apologies that it took me so long to retest.
Updates to test plan when using KTD (see comment 143):
1. Step 2 - with 0.0.0.0/0 or ::/0 in ILS-DI:AuthorizedIPs system preference, I
get Unauthorized IP address errors.
Changed it the IP address that was shown.
2. Step 7 should be: Try to place another hold using ILS-DI:
- Hold 4 (Higher-order Perl):
http://127.0.0.1:8080/cgi-bin/koha/ilsdi.pl?service=HoldTitle&patron_id=19&…'127.0.0.1'
Still getting test failures:
prove t/db_dependent/Reserves.t - passes if I increase the number of tests to
72
prove t/db_dependent/Holds.t
t/db_dependent/Holds.t .. 1/74
# Failed test '$branch_1 patron allowed to reserve $branch_2 item with
IndependentBranches OFF (bug 2394)'
# at t/db_dependent/Holds.t line 280.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test '... unless canreservefromotherbranches is ON (bug 2394)'
# at t/db_dependent/Holds.t line 295.
# Failed test 'Patron can reserve damaged item with AllowHoldsOnDamagedItems
enabled'
# at t/db_dependent/Holds.t line 349.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test 'Patron can place hold on item that is not for loan but
holdable ( notforloan < 0 )'
# at t/db_dependent/Holds.t line 387.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test 'can request item if we are not checking holds counts, but only
if policy allows or forbids it'
# at t/db_dependent/Holds.t line 431.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test 'cannot request item if policy that matches on item-level item
type forbids it'
# at t/db_dependent/Holds.t line 449.
# got: 'tooManyReserves'
# expected: 'noReservesAllowed'
t/db_dependent/Holds.t .. 52/74
# Failed test 'cannot request item if policy that matches on item-level item
type forbids it even if ignoring counts'
# at t/db_dependent/Holds.t line 453.
# got: 'tooManyReserves'
# expected: 'noReservesAllowed'
# Failed test 'A biblio-level hold already exists - another hold can
be placed on a specific item item'
# at t/db_dependent/Holds.t line 628.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test 'A biblio-level hold already exists - another hold can
be placed on a specific item item'
# at t/db_dependent/Holds.t line 628.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test 'A item-level hold already exists and
holds_per_record=1, another hold cannot be placed on this record'
# at t/db_dependent/Holds.t line 658.
# got: 'tooManyReserves'
# expected: 'tooManyHoldsForThisRecord'
# Failed test 'A item-level hold already exists and
holds_per_record=1 - tooManyHoldsForThisRecord has priority over
tooManyReserves'
# at t/db_dependent/Holds.t line 673.
# got: 'tooManyReserves'
# expected: 'tooManyHoldsForThisRecord'
# Failed test 'A item-level hold already exists but
holds_per_record=2- another item-level hold can be placed on this record'
# at t/db_dependent/Holds.t line 688.
# got: 'tooManyReserves'
# expected: 'OK'
# Looks like you failed 5 tests of 7.
# Failed test 'tooManyHoldsForThisRecord + tooManyReserves +
itemAlreadyOnHold'
# at t/db_dependent/Holds.t line 719.
# Looks like you failed 1 test of 2.
# Failed test 'CanItemBeReserved'
# at t/db_dependent/Holds.t line 720.
# Failed test 'CanItemBeReserved should return 'notReservable''
# at t/db_dependent/Holds.t line 760.
# got: 'tooManyReserves'
# expected: 'notReservable'
# Failed test 'CanItemBeReserved should use PatronLibrary rule when
ReservesControlBranch set to 'PatronLibrary''
# at t/db_dependent/Holds.t line 769.
# got: 'tooManyReserves'
# expected: 'cannotReserveFromOtherBranches'
# Failed test 'CanItemBeReserved should use item home library rule when
ReservesControlBranch set to 'ItemsHomeLibrary''
# at t/db_dependent/Holds.t line 775.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test 'CanItemBeReserved should return 'OK''
# at t/db_dependent/Holds.t line 782.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test 'Patron can reserve item if checking policy but not counts'
# at t/db_dependent/Holds.t line 829.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test 'Patron can place hold with no borrower circ rules'
# at t/db_dependent/Holds.t line 877.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test 'Patron can place hold with branch/category rule of 5,
category rule of 3'
# at t/db_dependent/Holds.t line 898.
# got: 'tooManyReserves'
# expected: 'OK'
# Failed test 'Patron can place hold with branch/category rule of 5,
category rule of 5'
# at t/db_dependent/Holds.t line 918.
# got: 'tooManyReserves'
# expected: 'OK'
# Looks like you failed 3 tests of 6.
# Failed test 'Test max_holds per library/patron category'
# at t/db_dependent/Holds.t line 919.
t/db_dependent/Holds.t .. 63/74
# Failed test 'Patron can reserve item with 2 reserves daily cap'
# at t/db_dependent/Holds.t line 1050.
# Structures begin differing at:
# $got->{status} = 'tooManyReserves'
# $expected->{status} = 'OK'
# Failed test 'Patron cannot a third item with 2 reserves daily cap'
# at t/db_dependent/Holds.t line 1065.
# Structures begin differing at:
# $got->{limit} = '1'
# $expected->{limit} = '2'
# Failed test 'Patron can reserve item with 2 bib level hold placed on
different days, 2 reserves daily cap'
# at t/db_dependent/Holds.t line 1076.
# Structures begin differing at:
# $got->{status} = 'tooManyReserves'
# $expected->{status} = 'OK'
# Failed test 'Patron can reserve if holds_per_day is undef (i.e. undef
is unlimited daily cap)'
# at t/db_dependent/Holds.t line 1136.
# Structures begin differing at:
# $got->{status} = 'tooManyReserves'
# $expected->{status} = 'OK'
# Failed test 'Unlimited daily holds, but reached reservesallowed'
# at t/db_dependent/Holds.t line 1149.
# Structures begin differing at:
# $got->{limit} = '1'
# $expected->{limit} = '3'
# Failed test 'Unlimited daily holds, but reached reservesallowed'
# at t/db_dependent/Holds.t line 1157.
# Structures begin differing at:
# $got->{limit} = '1'
# $expected->{limit} = '3'
# Looks like you failed 6 tests of 10.
# Failed test 'CanItemBeReserved / holds_per_day tests'
# at t/db_dependent/Holds.t line 1164.
t/db_dependent/Holds.t .. 68/74
# Failed test 'Patron of specified category can place 1 hold on specified
itemtype if library rule for all types and categories set to 2'
# at t/db_dependent/Holds.t line 1820.
# Structures begin differing at:
# $got->{status} = 'tooManyReserves'
# $expected->{status} = 'OK'
# Looks like you failed 1 test of 3.
# Failed test 'CanItemBeReserved rule precedence tests'
# at t/db_dependent/Holds.t line 1828.
t/db_dependent/Holds.t .. 71/74 # Looks like you failed 16 tests of 74.
t/db_dependent/Holds.t .. Dubious, test returned 16 (wstat 4096, 0x1000)
Failed 16/74 subtests
Test Summary Report
-------------------
t/db_dependent/Holds.t (Wstat: 4096 (exited 16) Tests: 74 Failed: 16)
Failed tests: 33, 35, 38, 43, 50-57, 60, 62, 64, 69
Non-zero exit status: 16
Files=1, Tests=74, 8 wallclock secs ( 0.03 usr 0.01 sys + 5.98 cusr 1.43
csys = 7.45 CPU)
Result: FAIL
--
You are receiving this mail because:
You are watching all bug changes.
1
0